Не загружается плеер и висит постоянно логотип WD

Обсуждение WD TV Live (SMP8655)

Moderator: Модераторы

Re: Не загружается плеер и висит постоянно логотип WD

Postby konstantin42 on Thu May 12, 2016 18:35

Прошу помощи!
Несколько лет назад внезапно и без всяких предупреждений умер WD TV Live. Пробовал сдать в ремонт - у кого программатора нет, у кого прошивки. В общем, тогда не получилось. На днях на работе пришлось делать переходник COM-UART заодно и свою железку подключил. Лог прилагаю, yamon жив. Одна беда - сам сумел только прочитать, что какие-то проблемы с flash. Ни yamonовских команд, ни что делать дальше не знаю. Прошу старших по опыту товарищей помочь. Железка, в общем то, неплохая, может удастся оживить.
You do not have the required permissions to view the files attached to this post.
konstantin42
 
Posts: 6
Joined: Thu May 12, 2016 18:15

Re: Не загружается плеер и висит постоянно логотип WD

Postby Gennadyi on Sun May 15, 2016 20:02

YAMON в логе отсутствует, надо грузиться с HDD
Gennadyi
Moderator
 
Posts: 942
Joined: Mon Nov 01, 2004 16:43

Re: Не загружается плеер и висит постоянно логотип WD

Postby konstantin42 on Mon May 16, 2016 18:26

Gennadyi wrote:YAMON в логе отсутствует, надо грузиться с HDD

Yamon точно жив, просто в этом логе я в него не заходил. Надо было выложить лог с заходом в yamon?
konstantin42
 
Posts: 6
Joined: Thu May 12, 2016 18:15

Re: Не загружается плеер и висит постоянно логотип WD

Postby Gennadyi on Tue May 17, 2016 13:10

konstantin42 wrote:
Gennadyi wrote:YAMON в логе отсутствует, надо грузиться с HDD

Yamon точно жив, просто в этом логе я в него не заходил. Надо было выложить лог с заходом в yamon?

Да, и желательно log запуска YAMON с HDD !
Gennadyi
Moderator
 
Posts: 942
Joined: Mon Nov 01, 2004 16:43

Re: Не загружается плеер и висит постоянно логотип WD

Postby konstantin42 on Tue May 17, 2016 19:37

Вот с загруженным yamonом. Про HDD не понял. Вы имеете в виду HDD подключенный к USB? (Внутреннего SATA нет).
You do not have the required permissions to view the files attached to this post.
konstantin42
 
Posts: 6
Joined: Thu May 12, 2016 18:15

Re: Не загружается плеер и висит постоянно логотип WD

Postby Gennadyi on Wed May 18, 2016 16:04

konstantin42 wrote:Вот с загруженным yamonом. Про HDD не понял. Вы имеете в виду HDD подключенный к USB? (Внутреннего SATA нет).

Плохо, что "Внутреннего SATA нет"
Если сбоит чип флеш-памяти с прошивкой, то его нужно форматировать заново, а при этом можно "окирпичить" устройство.
Лучше всего в Вашем случае - снять чип флеш-памяти с платы и прошить на программаторе, потом запаять обратно
Gennadyi
Moderator
 
Posts: 942
Joined: Mon Nov 01, 2004 16:43

Re: Не загружается плеер и висит постоянно логотип WD

Postby konstantin42 on Wed May 18, 2016 18:36

К сожалению, не в нашем городе. Сервисные центры не берутся. А других вариантов нет? Пока читал тему, видел, что многие решили похожую проблему без выпаивания flash.
konstantin42
 
Posts: 6
Joined: Thu May 12, 2016 18:15

Re: Не загружается плеер и висит постоянно логотип WD

Postby Gennadyi on Wed May 18, 2016 19:06

konstantin42 wrote:К сожалению, не в нашем городе. Сервисные центры не берутся. А других вариантов нет? Пока читал тему, видел, что многие решили похожую проблему без выпаивания flash.

У вас ядро линукса грузится ?
после этого :
Code: Select all
ROMFS found at 0x0x88100000, Volume name = MIPSLINUX_XLOAD
Found 1 file(s) to be processed in ROMFS.
Processing vmlinux_xload.zbf (start: 0x88100090, size: 0x002b3664)
  Checking zboot file signature .. OK.
  Warning: header version mismatched.
   *** Fully Encrypted.
src addr = 0xb1800000, dest addr = 0x13000000, is_dest_gaddr = 0x00000010
XLOADING src=0x81800000, dest=0x13000000, size=0x002b3644
xload.c:63: Waiting for XLOAD completion.
xload.c:73: XLOAD done, status = 0xbb.
XLOAD failed.
Done with container 1.
reading z.boot2 (vzx=0xbbd0bcbc) is 0x003c0000
Reading NAND CS0, addr 0x003c0000, maxsize 0x01000000 to 0x88100000
Not found.


что в логе ?
Gennadyi
Moderator
 
Posts: 942
Joined: Mon Nov 01, 2004 16:43

Re: Не загружается плеер и висит постоянно логотип WD

Postby konstantin42 on Wed May 18, 2016 19:33

Это полный лог. После этого загрузка останавливается, больше ничего не происходит - плеер стоит и мигает индикатором, на экране заставка WD.
konstantin42
 
Posts: 6
Joined: Thu May 12, 2016 18:15

Re: Не загружается плеер и висит постоянно логотип WD

Postby Gennadyi on Thu May 19, 2016 08:28

konstantin42 wrote:Это полный лог. После этого загрузка останавливается, больше ничего не происходит - плеер стоит и мигает индикатором, на экране заставка WD.

Можно попробовать перезаписать раздел с ядром линукса
Я быстро не скажу как это сделать (нет у меня WD), но может кто из делавших это на своем плеере откликнется
Gennadyi
Moderator
 
Posts: 942
Joined: Mon Nov 01, 2004 16:43

PreviousNext

Return to WD TV Live

Who is online

Users browsing this forum: Web crawler and 0 guests