Sigma DMB1320v5 help

Обсуждение других медиа плееров на SMP864x(5x) и общих вопросов эксплуатации

Moderator: Модераторы

Sigma DMB1320v5 help

Postby yamon on Tue Jan 17, 2017 20:05

Hello, i have a board labelled as DMB1320v5 but suddendly stop working. I connect to the board using the port DEBUG and a TTL-USB device. In the serial console i see:

Code: Select all
3cidxs696b15f57c540829defeeee9f4a092007337a124S                                                                                                                         
                                                                                                                                                                       
#xos2P52-100 (sfla 128kbytes. subid 0x00/a8) [serial#ae7ab16bf6d63928b89b917134904ce0]                                                                                 
#stepxmb 0xb5                                                                                                                                                           
No valid zxenv found in device group 0 CS#0                                                                                                                             
No valid zxenv found in device group 0 CS#1                                                                                                                             
No valid zxenv found in device group 1 CS#0                                                                                                                             
No valid zxenv found in device group 1 CS#1                                                                                                                             
No valid zxenv found in device group 2 CS#0                                                                                                                             
Failed to init devtype 4 CS#0                                                                                                                                           
Failed to init devtype 4 CS#1


So, i read in this forum and see that i can to boot from the SATA disk using this method:

Code: Select all
sudo fdisk /dev/sdc
p
1
a
w


and using the firmware available in intenet DMB1320V5_BS3_8653_3.6.13_201511192358.tar.gz

so i do:

Code: Select all
dd if=DMB1320V5_boot_8653_1.0.3.3920_201511192335.img of=/dev/sdc1 bs=1
dd if=DMB1320V5_logo_8653_1.0.3.3920_201511192335.img of=/dev/sdc1 bs=1 seek=1024
dd if=DMB1320V5_kernel_8653_1.0.3.3920_201511192335.img of=/dev/sdc1 bs=1 seek=1280


and then connect the SATA HDD to the board and power on, and in the serial console i see:

Code: Select all
3cidxs696b15f57c540829defeeee9f4a092007337a124S                                                                                                                         
                                                                                                                                                                       
#xos2P52-100 (sfla 128kbytes. subid 0x00/a8) [serial#ae7ab16bf6d63928b89b917134904ce0]                                                                                 
#stepxmb 0xb5                                                                                                                                                           
No valid zxenv found in device group 0 CS#0                                                                                                                             
No valid zxenv found in device group 0 CS#1                                                                                                                             
No valid zxenv found in device group 1 CS#0                                                                                                                             
No valid zxenv found in device group 1 CS#1                                                                                                                             
No valid zxenv found in device group 2 CS#0                                                                                                                             
SATA drive spin-up in progress, please standby...                                                                                                                       
#DRAM setup (method=0x10015858) ...                                                                                                                                     
#DRAM0 Window  :    0x#28#28#28#2a# (20)                                                                                                                               
#DRAM0 Settings: WD=0x0b0a0b0a RG=0x0909090a RR=0x0909090a RF=0x0a0b090b                                                                                               
#poisoned 65536 pages with 0xff35591f                                                                                                                                   
#step6 @0x00060914 sr=0x00000000                                                                                                                                       
#step7                                                                                                                                                                 
--- review xmasboot/configs/950-E2.config for details [xmbb7-ezboot98-nand_st2] ---                                                                                     
xloadsize=57924                                                                                                                                                         
xload rc=6                                                                                                                                                             
subrom SHA-256: 0043573e6613e8be4373c0259bdfe10911c93769ea113cf328c2443b3ce0e3db                                                                                       
ezboot98 @0xd00e5a94 (nand_st2) (actual cpu=@499MHz/dsp=333MHz/sys=333MHz)                                                                                             
on 8653 rev ES2 (subid 0x00) a2=0x00000002 a3=0x00000003                                                                                                               
step12                                                                                                                                                                 
#step22                                                                                                                                                                 
ruamm0 [0x84000000,0x8f9f8000[ (~195002368 bytes)                                                                                                                       
[0x8f9b8000,xos_public_ga=0x8f9c0000[ and [0x8f9e0000,0x8f9f7fff[ are lost for alignment)                                                                               
ex_ga=0x8f9b7cd4                                                                                                                                                       
[0x8f1a7cbc,ios_ga=0x8f400000[ and [0x8f800000,0x8f9a7cbb[ are lost for alignment)                                                                                     
GW32 0x0006f008 0x80000000 [va=0x84000000]                                                                                                                             
GW32 0x0006f00c 0x84000000 [va=0x88000000]                                                                                                                             
GW32 0x0006f010 0x88000000 [va=0x8c000000]                                                                                                                             
step33                                                                                                                                                                 
xos2k client version=19, server version=19                                                                                                                             
xos2 SHA-1 = 696b15f57c540829defeeee9f4a092007337a124 (version 0x52)                                                                                                   
xos2 serial = ae7ab16bf6d63928b89b917134904ce0                                                                                                                         
Using zbootxenv ga=0x8f1a3cb0 (va=0xbb1a3cb0)                                                                                                                           
                                                                                                                                                                       
**************************************                                                                                                                                 
* SMP86xx zboot start ...                                                                                                                                               
* Version: 3.1.0                                                                                                                                                       
* Started at 0xd00ecdb0.                                                                                                                                               
* Configurations (chip revision: 3):                                                                                                                                   
*    Enabled checkpoints.                                                                                                                                               
**************************************                                                                                                                                 
DRAM0 dunit_cfg/delay0_ctrl (0x35140017/0x4565132b).                                                                                                                   
DRAM1 dunit_cfg/delay0_ctrl (NA/NA).                                                                                                                                   
Using UART port 0 as console.                                                                                                                                           
Board ID.: SMP8652                                                                                                                                                     
Setting up H/W from XENV block at 0xbb1a3cb0.                                                                                                                           
  Setting <SYSCLK avclk_mux> to 0x17400000.                                                                                                                             
  Setting <SYSCLK hostclk_mux> to 0x00000130.                                                                                                                           
  Setting <IRQ rise edge trigger lo> to 0xff28ca06.                                                                                                                     
  Setting <IRQ fall edge trigger lo> to 0x0000c000.                                                                                                                     
  Setting <IRQ rise edge trigger hi> to 0x8c10001f.                                                                                                                     
  Setting <IRQ fall edge trigger hi> to 0x00000000.                                                                                                                     
  Setting <IRQ GPIO map> to 0x000a0800.                                                                                                                                 
  Setting <PB default timing> to 0x03080202.                                                                                                                           
  Keeping <PB timing0> to 0x03080202.                                                                                                                                   
  Keeping <PB Use timing0> to 0x000003f3.                                                                                                                               
  Setting <PB timing1> to 0x10101010.                                                                                                                                   
  Setting <PB Use timing1> to 0x000003f4.                                                                                                                               
  Setting <PB CS Config> to 0x00370043.                                                                                                                                 
  Enabled Devices: 0x00233ffc                                                                                                                                           
    PCIHost Ethernet IR FIP I2CM I2CS SDIO USB PCIDev1 PCIDev2 PCIDev3 PCIDev4 SATA SCARD                                                                               
  PCI IRQ routing:                                                                                                                                                     
    IDSEL 1: INTA(#14) INTB(#14) INTC(#14) INTD(#14)                                                                                                                   
    IDSEL 2: INTA(#14) INTB(#14) INTC(#14) INTD(#14)                                                                                                                   
    IDSEL 3: INTA(#14) INTB(#14) INTC(#14) INTD(#14)                                                                                                                   
    IDSEL 4: INTA(#14) INTB(#14) INTC(#14) INTD(#14)                                                                                                                   
  Smartcard pin assignments:                                                                                                                                           
    OFF pin = 26                                                                                                                                                       
    5V pin = 1                                                                                                                                                         
    CMD pin = 0                                                                                                                                                         
cd#0 disabled                                                                                                                                                           
cd#1 disabled                                                                                                                                                           
cd#2 want 96000000Hz: setting of 0x0000000021c00000-2^28                                                                                                               
cd#2 cannot measure                                                                                                                                                     
cd#3 disabled                                                                                                                                                           
cd#4 disabled                                                                                                                                                           
cd#5 disabled                                                                                                                                                           
cd#6 disabled                                                                                                                                                           
cd#7 disabled                                                                                                                                                           
cd#8 disabled                                                                                                                                                           
cd#9 disabled                                                                                                                                                           
cd#10 disabled                                                                                                                                                         
cd#11 disabled                                                                                                                                                         
  GPIO dir/data = 0x00000800/0x00000000                                                                                                                                 
  UART0 GPIO mode/dir/data = 0x6e/0x00/0x00                                                                                                                             
  UART1 GPIO mode/dir/data = 0x6e/0x00/0x00                                                                                                                             
  UART2 GPIO mode/dir/data = 0x6e/0x00/0x00                                                                                                                             
  MAC0: 00:16:e8:7a:b1:6b                                                                                                                                               
XENV block processing completed.                                                                                                                                       
Default boot index: 0                                                                                                                                                   
xmboot booted from devtype: 4, chipsel: 0, phyblocknum: 0                                                                                                               
No explicit boot order specified, using default boot order...                                                                                                           
ezboot buffers, setup in DRAM bank#0:                                                                                                                                   
  Alloting 2097152 bytes for heap.                                                                                                                                     
  Alloting 16777216 bytes for reading.                                                                                                                                 
  Alloting 16777216 bytes for decryption.                                                                                                                               
xmat romfs goes to 0x8f163ca0 (ga)                                                                                                                                     
xmat romfs goes to 0xb3163ca0 (va)                                                                                                                                     
Trying devtype=4 chipsel=0                                                                                                                                             
File xtask_loader.xload not found                                                                                                                                       
No xtask_loader.xload in xmat romfs, aborting                                                                                                                           
freeing xmat romfs buffer at 0x8f163c94                                                                                                                                 
xmat romfs process failed.                                                                                                                                             
Trying devtype=4 chipsel=0                                                                                                                                             
reading z.boot0 (vzx=0xbb1a3cb0) is 0x00080000                                                                                                                         
Found.                                                                                                                                                                 
ROMFS found at 0x0x01840000, Volume name = xmaterial                                                                                                                   
Found 3 file(s) to be processed in ROMFS.                                                                                                                               
Processing ios.bin.gz_8644_ES1_dev_0006.xload (start: 0x018400a0, size: 0x00020b54)                                                                                     
  Checking zboot file signature .. Not found.                                                                                                                           
Processing version (start: 0x01860c20, size: 0x0000000c)                                                                                                               
  Checking zboot file signature .. Not found.                                                                                                                           
Processing xtask_loader.xload (start: 0x01860c60, size: 0x00001894)                                                                                                     
  Checking zboot file signature .. Not found.                                                                                                                           
Done with container 0.                                                                                                                                                 
Skipping boot container 1.                                                                                                                                             
Skipping boot container 2.                                                                                                                                             
Skipping boot container 3.                                                                                                                                             
Skipping boot container 4.                                                                                                                                             
Skipping boot container 5.                                                                                                                                             
Skipping boot container 6.                                                                                                                                             
Skipping boot container 7.                                                                                                                                             
Trying devtype=4 chipsel=1                                                                                                                                             
Failed to init!                                                                                                                                                         
Boot failed (no bootable image found) ..                                                                                                                               
failure of zboot (nand_st2), now going to ub 


But im stuck here.

i read a documentation about how to run from the SATA HDD and in some part it say:

Note: The default ZXENV configuration for Sigma Reference boards does not enable stage1 booting from SATA. You should double-check to make sure that the ZXENV you intend to write to the SATA HDD will attempt to use SATA. You can check for the key z.bootdev_order (see XenvGuide for more information).


So, how do i edit the z.bootdev_order of the binary image?
Can anyone helpme?

Note: I have tried almost all Yamon_Boot files in this forum, and none work.

Sorry for my bad english.

This is the board:

Image
You do not have the required permissions to view the files attached to this post.
yamon
 
Posts: 3
Joined: Sat Jan 14, 2017 06:24


Re: Sigma DMB1320v5 help

Postby yamon on Tue Feb 14, 2017 05:44

Hello, i checked those files, but some links are dead. I also locate some Apache Tomcat software to manage this board, but that is not what im looking for. I just need to modify my Xenv for boot from HDD Sata. I have the original firmware copied directly from a working device.
yamon
 
Posts: 3
Joined: Sat Jan 14, 2017 06:24

Re: Sigma DMB1320v5 help

Postby Gennadyi on Wed Feb 15, 2017 21:11

yamon wrote: I have the original firmware copied directly from a working device.

Where is it ?
How to take it ?
Gennadyi
Moderator
 
Posts: 929
Joined: Mon Nov 01, 2004 16:43

Re: Sigma DMB1320v5 help

Postby yamon on Fri Mar 03, 2017 17:43

Gennadyi wrote:
yamon wrote: I have the original firmware copied directly from a working device.

Where is it ?
How to take it ?


i take it from a working device, running dd if=/mtdblock7 of=/mount/usb/dmb.img and the same to each memory block.

Code: Select all
0x00000000-0x02000000 : "hole flash"
0x00000000-0x000c0000 : "boot loader"
0x000c0000-0x00180000 : "logo"
0x00180000-0x00480000 : "root fs"
0x00480000-0x00680000 : "kernel"
0x00680000-0x00d80000 : "repair"
0x00d80000-0x00f80000 : "config"
0x00f80000-0x02000000 : "dmb"
yamon
 
Posts: 3
Joined: Sat Jan 14, 2017 06:24


Return to Other media players and common questions / Другие медиа плееры и общие вопросы

Who is online

Users browsing this forum: Web crawler and 1 guest